AnsweredAssumed Answered

st8 Discovery gdi-error [40201]: can't access configuration database

Question asked by 58916 on Mar 27, 2014
Latest reply on Jul 11, 2018 by Jim Kellar
Hi,

I'm trying to use the ST Visual Develop with the Cosmic st8 32k compiler.  I install everything and build the project.  That all works fine.  When I try to connect to the Discovery board with the debugger using Swim ST-link, I receive the following error:

Starting debug session...
 -> Emulator reset (usb://usb)...
  ** Connection error (usb://usb): gdi-error [40201]: can't access configuration database


 -> Failed to connect target.


I have tried uninstalling and re-installing everything including the drivers.  I've tried other target settings.  The only one that works is the simulator.

When I connect the Discovery board, my computer sees it as an external HD.  I get the pop-up window and can look at the links stored on the board.  I'm using Windows 7 64bit.

I should also add that after the above error message a windows 7 pop-up appears saying that gdb7 has stopped working and a red LED glows on the board.

Any help would be appreciated.

Regards,
Marc

Outcomes