AnsweredAssumed Answered

Nucleo-F103RB + IHM01A1 multi byte SPI communication fails

Question asked by horbach.markus on Jun 3, 2016
Latest reply on Nov 2, 2016 by fjosna.erlend
Hello all,

I am using a nucleo board with the IHM01A1 and created my own CubeMX Project to run one stepper Motor. so far, i managed to start the Motor with the Power_ON (0xB0) command and TIM3CH2 pwm Signal on STCK-Pin and can adjust the Speed of the Motor. Now, i want to adjust the Settings inside of the L6474 to fit to my Motor (12V / 1A) to get a higher Speed (it has almost no load, only a Spinning disc). at the Moment, i can only achive 2 rounds per second, at higher Speed the Motor get stuck, with the power on default Settings of the L6474. But every time I want to send a command with data as Parameter or with one or two respond Bytes, i only get the command Byte as a respond and the second Byte is Zero (see attached Picture from my logic analyser). I used DM00043117.pdf and DM00082126.pdf to build my own library for the L6474. (the x-cube-spn1 examples work fine with my Nucleo-F030R8/F401RE, so i expect the Hardware is OK.) What is my mistake ?

Best regards,
Markus.

PS: DM00043117.pdf, Page 42 says GetStatus is 0b11010000, DM00082126.pdf, Page 10 says GetStatus is 0b10110000. Typo ? which is correct ? I tried both values with same result.

Attachments

Outcomes