AnsweredAssumed Answered

make build boot.o error 2 on version 4.0

Question asked by colla.ivan on Dec 23, 2015
Latest reply on Dec 28, 2015 by colla.ivan
Good mornig.

I recently installed SPC5Studio 4.0 after SPC5Studio 3.5. 
I followed the guide, installed the GCC compiler and components. Then I imported the project on which I was warking. From that moment the compiler give me the same error:

make all 
Compiling boot.s
process_begin: CreateProcess(NULL, ppc-vle-gcc -x assembler-with-cpp -c -mcpu=e200zx -meabi -msdata=none -mnew-mnemonics -mregnames -mvle -Wa,-amhls=build/lst/boot.lst -DPPC_USE_VLE=1 -MD -MP -MF .dep/boot.o.d -I. -I./components/portable_spc5_hal_component/lib/include -I./components/spc56elxx_hal_drivers_component/lib/include -I./components/spc56elxx_osal_component/lib/include -I./components/spc56elxx_platform_component/cfg -I./components/portable_spc5_hal_component/cfg -I./components/spc56elxx_hal_board_initialization_component/cfg -I./components/spc56elxx_hal_drivers_component/cfg -I./components/spc56elxx_osal_component/cfg -I./source/ -I./source/Comm/ -I./source/Measures/ -I./source/ReadConfig/ -I./source/WaveGen/ -I./components ./components/spc56elxx_platform_component/lib/src/boot.s -o build/obj/boot.o, ...) failed.
make (e=2): Impossibile trovare il file specificato.


make: *** [build/obj/boot.o] Error 2

I verified the paths and the file boot.s is present in the project directory.
I clened the project and the components generated, re-generated the components sources and then compield, with the same results.

It is not clear what has changed with the new installation.

After some investigations, I discovered a difference on the Makefile generated by the SPC5Studio generation process. In the compiler settings, in the makefile at the root of the project, there is this line:

TRGT = ppc-vle-eabi-

Using this option the compiler doesn't find the boot.s file.

I tried to generate a new application via application wizard for testing and this works. Looking at the makefile, it seems that the difference is:

TRGT = ppc-freevle-eabi-

I changed the ootion in the makefile generated and with this option the compiling proceeds. 

But the compiling process stops on one of my source files, givin me a segmentation fault of the compiler.

I have just installed the new version 4.0 of SPC5Studio and the compiler FreePowerPC-VLE GCC 4.6.3 toolchain from the SPC5 Studio Market place.

Thanks.

Outcomes