AnsweredAssumed Answered

problem with DfuSe tool

Question asked by gharib.yasamin on Apr 25, 2015
Latest reply on Apr 28, 2015 by gharib.yasamin

Hi

 I want to use to DfuSe tool for my application. I use L6470 stepper motor driver and STM32F107RC microcontroller in my board. My DfuSe tool is V3.0.4. I load firmware to the board by using the DfuSe demonstration software corresponding to UM1691.

I use the “fwlibraries_V2_00_dspin_L6470H_DISC.dfu” file from ST site. I attached the file to my e-mail. The firmware is downloaded on my board correctly and it is verified.

I have two problems apparently.

First a problem has in “select target” part for SPI flash. I print screen the DfuSe tool window of my application and attached it to my e-mail.  In the “select target” part of window, I have 1 sector instead of 128 sectors. Why?

The second in “DFU mode version”, I have version number 2200 instead of 0200 in page 23 of UM1691.

Could you give me guidelines or solve my problem?

I would like to know my hardware (STM32F107RC) has problem or not?

 

Then I connected an 8 volt power to my motor power supply. My green led is switched on all at the same time without blinking. Then the red led is blinking some times and then orange led is blinking some times. Finally the green led and red led are switched on all at the same time without blinking.

When I press RESET button, the four LEDs will switch on one after the other by starting by the

green led and ending by the yellow led only one time.

 

I used the SPINFamily evaluation software GUI, and try to connect to board. But I get an error message which attached to my e-mail.

 

Thank you in advance for your help in this matter.

 

Regards

Yasamin Gharib

 

Outcomes