AnsweredAssumed Answered

Ethernet PHY Micrel 802RNLI Problem

Question asked by huigc001 on Oct 17, 2016
Latest reply on Oct 18, 2016 by Clive One
Hello Guys,

I have got a problem with the configuration of the ethernet PHY which I use. The problem occurs when i connect my PC and my custom board(which uses a STM32F107VCT). Under network settings I can see that the PHY is working in a way but the LAN-Connection tells me: "Not identified network". I have tried to ping my board but no reply. First of all I thought that the problem could be, because the frequency of the oscillator is wrong configured but then there was no attempt to connect to the PC like it was before. Then I knew that the default oscillator frequency (MCO) of 50MHz is the right one and there is no need to configure the frequency. I came up to this thought because of a blog which described the PHY like the frequency had to be set up. Anyway I'm pretty sure that the frequency is not the reason of the problem. As far as I understood the PHY address depends on the pin CRS/DV. There are only 2 unique identifiers possible, 0x3 and 0x0. When the output is low it means 0x0 and when the output is high it means 0x3. So I have read the pin and it's always 0. So I have set the PHY address to 0.
In a blog I have read that registers of PHYs are nearly the same. But in a blog I have read that 3 registers have to be set. I set those registers but there was no success. Still the same Problem: "Not identified network". Can anyone help me? Has anyone work with the ethernet PHY Micrel 8021RNLI before? By the way I'm using STM32CubeMX with the newest library version of STM32F107VCT to configure my board. What am I doing wrong?
#define PHY_SR 0x1e     /*!< Tranceiver Status Register */
#define PHY_Speed_Status    ((u16)0x0001)    /*!< Configured information of Speed: 10Mbps */
#define PHY_Duplex_Status   ((u16)0x0004)    /*!< Configured information of Duplex: Full-duplex */

Thank you in advance for your help.

Outcomes