AnsweredAssumed Answered

Code for USART1 on STM32F3-Discovery

Question asked by weiser.johann on Jul 16, 2016
Latest reply on Jul 17, 2016 by weiser.johann

Clive1 gave a simple code for sending data from the board to the PC via the USB-connection here:

https://my.st.com/public/STe2ecommunities/mcu/Lists/cortex_mx_stm32/Flat.aspx?RootFolder=https%3a%2f%2fmy%2est%2ecom%2fpublic%2fSTe2ecommunities%2fmcu%2fLists%2fcortex%5fmx%5fstm32%2fusart%20code&FolderCTID=0x01200200770978C69A1141439FE559EB459D7580009C4E14902C3CDE46A77F0FFD06506F5B&currentviews=1160#{85D10E25-9ABA-4616-AB29-512EDFAFB851}

I assume the data can be seen via a virtual COM port (e.g. via putty).

The code is running fine on the board (I added a led toggling in between). However I see no data on the PC. On my PC there is no virtual COM port visible - neither with nor without a connected board. I am working with a windows7 PC.

I tried already quite a lot. I tried it with the keil Toolset as well with the openSTM32 system. I installed different versions of the virtual com port (1.4.0 and 1.3.1 as well as with the standard virtual com port associated STLinkV2.1.).

Running code on the board (also communication via other usart interfaces) as well as debugging is okay.

I tried to start the virtual com port manually on the PC and I got error 10 (This device cannot start.).

Outcomes