AnsweredAssumed Answered

STM32F1 (Connectivity line) Cannot enter internal CAN bootloader

Question asked by riabovas.justas on Jun 20, 2016
Hello,
I'm also experiencing programs with internal bootloader.
I cannot connect to bootloader with my master USB-CAN device based on STM32F105.
Slave STM32F105 device does not respond to 0x79 message (does not acknowledge).

Moreover when I connect MHS Tiny-CAN logger instead of my master device and send 0x79 message from logger, slave device acknowledges first message and enters CAN bootloader.
After that I reconnect my master USB-CAN adapter and then communication with booloader works. I managed to program/read my application to slave device.

The setup of my system is:
about 60cm of CAN cable taken from automotive wiring harness, terminated in both ends with 120 Ohm resistor. I've also tried about 50 m long cable.
3.3V can transceivers SN65HVD233. Slope control pin is wired to GND through 10 kOm resistor, loopback pin wired to GND. Also tried with ADM3053BRWZ isolated CAN driver on master side. Results are the same.
Both processors run on 8 Mhz quarz.

When watching signals with oscilloscope I see that MHS logger makes about 500 mV higher signal difference in dominant state than my USB-CAN adapter when there is SN65HVD233 driver connected and there is no difference with ADM3053BRWZ. Nevertheless when I check signal going from transceiver to processor on my slave device bit by bit I can't find any difference. Timing looks the same.

I'm using ~50% sample point as suggested somewhere in these forums.

Where could be the magic?

Outcomes