AnsweredAssumed Answered

Debugger starts up at wrong address.. sometimes..

Question asked by wa.joans on Mar 22, 2016
Latest reply on Mar 22, 2016 by wa.joans
Hi All, 

I just started working on a STM32L151. I've setup the debugger to break at first instruction (not main), but when I start debugging the program counter stops at 0x1ff00b84 which isn't even a part of the flash (starting at 0x8000000). 

It gets wierd, because when i try resetting the debugging session (without downloading the program again), a couple of times it finally stops at the first instruction in my startup-file (startup_stm32l1xx_md.s) and everything runs smoothly until the next time I need the program the device and start the debugger again. 

I am really at the bare bottom here, and it really begins to take up time on the project. 

I use CoIDE with the compiler "GNU Tools ARM Embedded 4.8 2014q2". 
And I run on some custom HW that just arrived - though I've worked with STM32F for a some time, and never seen anything like it.. 

I've attached the startup file I'm using, if that helps.. 

Hope someone has an idea?

Attachments

Outcomes