AnsweredAssumed Answered

STM32F0 Hard Fault Error

Question asked by erickson.troy.001 on Mar 2, 2016
Latest reply on Mar 4, 2016 by AvaTar
Hi all,

The issue that I am having is that I having is last night I was programming and found that my code suddenly stopped functioning completely. After running in debug mode I found that the code immediately enters a hard fault. I tried removing and commenting out many lines of code to try to figure out what could have caused this issue. Attached is a picture of what I am seeing in debug mode, I have tried to set break points at many locations but cannot get to any of them.
It appears that this hard fault is occurring during the USB Initialization. The part that confuses me is that I have had the USB transmitting and receiving flawlessly prior to last night. Changes that were made were adding a timer (STM32CubeMX regenerated the code) and I believe that is it. The USB port is just sending the sensor data to the computer so via virtual com port for analyzing. 

Additional Information:
- Source code file WAS generated using STM32CubeMX
- USB port was configured as a CDC in device mode

Thanks for any help!