AnsweredAssumed Answered

STM32F030F4 / K6 bootloader via UART don't work for me

Question asked by gorkovenko.rodion on Dec 31, 2015
Latest reply on Jan 1, 2016 by gorkovenko.rodion
Dear Friends and Colleagues!

I'm interested to move from NXP chips to ST ones, so I've got a pair of devices and am currently trying to work with their bootloader via UART. The devices are

STMF030F4 (TSSOP-20)
STMF030K6 (LQFP-32)

I use FTDI-232 USB-to-UART cable (the same I use for uploading code to LPCs, so it works) and has the following wiring:

+3.3 V to VDD
GND to VSS
+3.3 V to BOOT0 (pin 1 in tssop)
RXD from FTDI to PA9 (e.g. pin 17 in tssop)
TXD from FTDI to PA10 (e.g. pin 18 in tssop)

I also temporarily connect NRST (pin 4) to GND to reset the device.

However I could not get any uploading tool work with it. They do not see device. When I tried to write small program send 0x7F (8-bit, even parity, 1 stop bit) I do not get any response from device. Though I've tested the cable with other device to make sure it is ok...

What may I miss there?

UPD: I have 5kOhm pull-up from PA9 (I also tried another pull-up to PA10 though I see no sense in this)... Also I should note that my cable have 5V levels though I think it should work anyway as the device is 5v tolerant - is this correct?

Outcomes