AnsweredAssumed Answered

Cannot connect to new STM32F3 Target

Question asked by berner.kevin on Dec 24, 2015
Latest reply on Dec 29, 2015 by Clive One

Hi All,

I’m having a problem that I hope folks might be able to assist with.   I have built 100s of STM32F1 target based multirotor flight controllers.  Never once have I had a problem programming the F1.  Decided to make an F3 version of the flight controller.   I basically reverse engineered this flight controller:

http://www.readymaderc.com/store/index.php?main_page=product_info&cPath=76_156&products_id=4221

So, I made a F3 breakout board with just the basics on board for prototyping purposes.  Put it all together and have now spent days trying to get the F3 to connect so I can flash it. 

Problem:  I cannot connect to brand new STM32F3 targets via SWD no matter what I do.  Using ST-Link and DiscoF3 I cannot get it to recognize the F3.   When I click on Settings, it shows “Detection Fail” and will not connect. 

I’ve double/triple checked all connections and orientation are correct. 
- NRST has 10k pull-up to 3.3v.  Shows 3.3v on power up.
- Caps all around per typical setup
- VBat/Vdd at 3.3v
- Vss all grounded
- No Shorts
- DiscoF3 jumpers pulled for SWD
- 10k pulldown on Boot0

I decided to take an F3 and put it on one of my F1 target boards (barebones) and still will not connect. 

Things I’ve done/checked:

       
  1. Tried 3 different brand new F3s on 3 different boards.   2 of my breakout boards and 1 of my f1 target boards (barebones).
  2.    
  3. Checked to make sure all connections and orientation is correct. 
  4.    
  5. Ran each pin individually to make sure no shorts. 
  6.    
  7. DiscoF3 works perfect.  Can connect to F1 and other F3 targets with no problem.  Connects just fine to the F3 target Flight controller in the hyperlink above.
  8.    
  9. Tried to connect via UART/Serial o PA9/10.  No joy. 
  10.    
  11. I’ve pulled Boot0 high. No Joy.
  12.    
  13. Tried to send 0x7E via serial, no response.  
  14.    
  15. SWD Connections are short and I'm 100% sure they are correct.  No problem with F1 or existing F3 targets.  Just when I try to connect to a brand new F3 via breakout board or F1 board (with new F3).

I’m out of ideas and ready to throw in the towel.  No way all three F3s I've tried were defective.   I'm sure I'm just missing something simple.   Hopefully someone can point me in the right direction.

Thanks in advance for the help.

STM32F3 breakout board I threw together:


stm%20Breakout.png

Outcomes