AnsweredAssumed Answered

no data on udp

Question asked by mosig.patrick on Oct 8, 2015
Latest reply on Dec 14, 2015 by neitzke.emerson.001
Hello,

i have a device, thats streaming data on udp Port 23. I want to read this data with a SPWF01S.
The device creates a Network with no encryption in adhoc-mode (channel 11)
I used the following to get a connection:

       
  • AT+S.SCFG=wifi_mode,0
  •    
  • AT+S.SCFG=wifi_priv_mode,0
  •    
  • AT+S.SSIDTXT=test
  •    
  • AT+S.SCFG=wifi_mode,2
  •    
  • AT+S.SCFG=ip_ipaddr,192.168.0.111
  •    
  • AT+S.SCFG=ip_gw,192.168.0.1
  •    
  • AT+S.SCFG=ip_dns,192.168.0.1
  •    
  • AT+S.SCFG=ip_netmask,255.255.255.0
  •    
  • AT+S.SCFG=ip_use_dhcp,0
  •    
  • AT+S.SCFG=wifi_channelnum,11
  •    
  • AT&W
  •    
  • AT+CFUN=1
(i also tried it without the manuell ip-settings)

on a browser on a pc i can reach the website of the SPWF01S if i type in the ip-adress,
so there is a connection.

Now i open a socket like this:
       
  • AT+S.SOCKON=192.168.0.74,23,u,ind
but if i use  AT+S.SOCKQ=00 to see if there are any data, it is always empty (but the device is sending some, i see them on the pc)

I also tried AT+S.SOCKD=23, with the same result.

What am i doing wrong?

Kind Regards
Patrick

Outcomes