AnsweredAssumed Answered

Hardfault error while running osxMotionAR example project

Question asked by p_p.arun_prakashh on Sep 28, 2015
I am getting one hardfault error after calling the osx_MotionAR_Initialize() API. I am using STM32F401 Nucleo board with X-NUCLEO-IKS01A1 sensor expansion board. I have installed required software and i tried to run the example project available from the directory Projects\STM32F4xx-Nucleo\Applications\DataLogActivity\EWARM in IAR IDE. But i am getting hardfault after calling osx_MotionAR_Initialize() API.What could be the problem? i didn't changed anything in the project, just opened the existing project in the workspace. I have tried the same in keil also but result is same. Please help me to figure out the problem.

As per the user guide i have edited the osx_license.h file. I am getting license error when osx_mar_license[3][4]  buffer filled with zeros. After editing the license buffer with license, i am getting hardfault error.
License wizard generate following three codes

Node Code:     1932DD005128B2C33690DA1103A823AA
Site Code:     ADBE59CA8D03254E20F816DD334B46E8
License Code:     5D1E454C6584BFE888D1AC4F787B0850

and i edited buffer as shown below. Is there any mistake in this?
//uint32_t osx_mar_license[3][4] =
//{
//     { 0x1932DD00, 0x5128B2C3, 0x3690DA11, 0x03A823AA },
//     { 0xADBE59CA, 0x8D03254E, 0x20F816DD, 0x334B46E8 },
//     { 0x5D1E454C, 0x6584BFE8, 0x88D1AC4F, 0x787B0850 }   
//}; 



Outcomes