AnsweredAssumed Answered

No ethernet on some switches

Question asked by man.demo on Oct 15, 2015
Latest reply on Oct 15, 2015 by peacock.jack.003

Guys, I have a strange behavior using STM32F373RCT6 with ENC28J60 Ethernet IC:

Overview: The IC is connected to STM controller via SPI. I’ve attached the schematics. It’s configured to half-duplex mode, for compatibility reasons. I’m using UDP protocol to send some data from a PC to the STM. The STM returns an “OK” packet via UDP when it receives the data. Everything works fine if I have a direct connection between the PC and the STM.

Problem: The strange thing happens when I connect the PC to the STM via an Ethernet switch:
On some ports the communication is working, on some it does not – there is no pattern… at least I cannot find one.

       
  • I’ve tried with different switches (Siemens, TP-Link, HP ProCurve) – no difference.
  •    
  • I’ve tried with different Ethernet cables (4-wire, 8 wire, crossed) – no difference.
  •    
  • I’ve tried with different duplex combinations (half, full, auto) – no difference. 

Do someone knows what might be the reason?
Or can someone please advise what more to check to identify the reason?

If any other info is needed to diagnose the problem, please ask and I’ll provide it.

Thanks in advance for the time spent!
J

Attachments

Outcomes