AnsweredAssumed Answered

SWD not working on STM32F303RET6

Question asked by SviMik on Sep 22, 2015
Latest reply on Sep 24, 2015 by Clive One
Hi all,

My problem is quite unusual, and I need some new ideas.

I can't make SWD connection working on STM32F303RET6. I'm constantly getting "Can not connect to target" message.
       
  • I have installed the latest version of ST-LINK, and also upgraded the debugger firmware to the latest version.
       
  • I have tried the same debugger with STM32F303CCT6, and it works fine.
       
  • I tried two STM32F303RET6 MCUs to make sure this is not an occasional MCU defect.
       
  • I checked the errata sheet, and didn't found any SWD problem there.
       
  • I have checked the electrical connections dozen times, comparing with both STM32CubeMX and MCU datasheet.
       
  • SWD pins aren't used in my circuit
       
  • Empty MCU (new, without any firmware) acts the same way.
       
  • I'm still able to boot in DFU mode, and upload firmware with USB. This makes me think the MCU is powered up correctly.

What could possibly go wrong?

Outcomes