AnsweredAssumed Answered

GUI Library STM3241G EVAL BOARD PROBLEM

Question asked by melo.camilo on Jul 12, 2014
Latest reply on Jul 14, 2014 by Montassar BEN ROMDHANE
Hi to all,

I'm really new with STM products, I have a discover board STM3241G-EVAL, I'm going to try to explain my problem with the GUI embedded library:

- The configuration of the source files is done, I can display icons, text, buttons in the LCD.
- I use the STM software to generate the screens for my app, but here is my problem, I wanna use icons like buttons, but if a screen have more that 3 icons, the program goes to the BusFault_Handler function.

Here is a part of my code:

This part is when the code runs fine:

GL_Page_TypeDef *CurrentScreen;
GL_Page_TypeDef inicio;

Create_PageObj( &inicio ); 

GL_PageControls_TypeDef* TEXT2= NewLabel(5,(uint8_t*)"HOLA MUNDO",GL_HORIZONTAL,GL_FONT_SMALL,TEXT1Color);
    AddPageControlObj(303,120,TEXT2,&inicio);
       
        /*GL_PageControls_TypeDef* ImgConfig= NewIcon (1,ImgConfig_Image,30,30,GL_NULL);
    AddPageControlObj(303,176,ImgConfig,&inicio);
        */
        GL_PageControls_TypeDef* ImgTerminal= NewIcon (2,ImgTerminal_Image,30,30,GL_NULL);
    AddPageControlObj(303,64,ImgTerminal,&inicio);
        
        GL_PageControls_TypeDef* ImgSave= NewIcon (3,ImgSave_Image,30,30,GL_NULL);
    AddPageControlObj(303,16,ImgSave,&inicio);

inicio.ShowPage(&inicio,GL_TRUE);
 /***************************************/

but, if you uncomment the line that appear like comment, then, the problem happens and the BusFault appear

Outcomes