AnsweredAssumed Answered

Programming external application with stm32 Discovery

Question asked by heizenberg.shagas on Aug 23, 2015
Latest reply on Aug 23, 2015 by heizenberg.shagas
Hello,

I'm trying to program an external prototype board that I made using the same MCU as on the Discovery (stm32f407VG) and am getting the following error:

Error: Flash driver function execute timeout
     Erase:    [  0%]

I have tried searching for this and found similar topics but could not find helpful advice.
I use coocox to program the Discovery and it works fine but it fails to program the external application. Here is how I have it wired up:

All the VDD pins to 3v from the discovery , all the VSS to GND (including VDDA and VSSA) , the VCAP1 and VCAP2 connected to VSS through 2.4uf caps .The SW CLK and SW IO pins to PA14 and PA13 and the NRST pin (without pullups). 
I removed the  CN3 jumpers on the discovery of course.

Can someone please give me some advice on what to do here? I've been trying to get it to run for the past 4 days now with no success.  Thanks in advance.
I'm using CooIDE. I tried CoFlash , doesn't work either.

Outcomes