AnsweredAssumed Answered

[Solved] Getting desperate with my faulty custom stm32f4 board

Question asked by pierre on Aug 19, 2015
Latest reply on Aug 20, 2015 by pierre
Hello,

I made a PCB with a STM32F429IGT6 (f429 176 pins) and I want to test it but... I cannot flash my stm. I've tried many things and I'm started to think I might have missed something so if some experienced stm32f4 users could take a look at my stuff and tell me if anything's wrong that would be pretty awesome.

Here are some details about my board.

I soldered everything myself but tested many pins and there is no evidence of shorts or whatever. Everything seems fine on the PCB.

I have connected my stm32 to the st link device this way:
 - VCC and GND of course
 - SWCLK on SYS_JTCK-SWCLK (137/PA14)
 - SWDIO on SYS_JTMS-SWDIO (127/PA13)
 - TRACESWO on SYS_JTDO-SWO (161/PB13)
 - NRST on NRST (31) [NB: there's no pull and no pull down on NRST].

About the µC, I have more or less copied the stm32f429i-disco schematics (see below).

power.png

Hence, there are:
- 100 nF capacitors on every VDD
- 1.1 uF caps on VDDA and VREF+ with a bead between the caps and VDD
- 1 uF cap at VBAT (+ connection to VDD)
- PDR_ON is connected to VDD
- VCAP1 and VCAP2 are connected to GND with 2.2 uF caps.
All caps are very close to the stm.

Also:
- BOOT0 is connected to GND.

Something important: after powering the board (which delivers a 3.3V signal to the stm), I noticed that both VCAP1 and VCAP2 were at 0V, although I've read somewhere they shouldn't be. All other pins (Vdd, Vbat, etc) have a correct voltage.

Finally, when I try to connect to the µC, st-link tells me "Can not connect to target!". I've tried normal and "connect under reset" modes (SWD) but nothing works.

Does anybody know what could be wrong?

Many thanks,
Pierre.

Outcomes