AnsweredAssumed Answered

FATFS frustrating problem

Question asked by Wasilewski.Piotr on Aug 7, 2015
Hello again!

I'm trying to read from sd card using SDIO. I've succesed to tun it on STM32f103 @72Mhz and after a while I managed to read at about 10Mb/s. But when I ported this files to STM32f407 it hangs somewhere in f_open function. Are they really that different ? I 've setup everything and turned on clock for sdio, gpio. The hardware is 100% ok, because I tried  this lib
ONE  and it works, but at poor speed of read at 3,5Mb/s. I've also tried clive1's library from here Unfortunately it hangs up in CMD0 timeout loop. I tried to connect these two libs, but it's very hard due to the fact they use different FatFS version. Now I don't know what to do . Should I try to make this 3.5Mb/s lib faster, or try to launch clive1's lib. 

What do You think may cause my stm32f103 lib doesn't work on stm32f407 ? 

Thank You in advance !


EDIT: I managed to launch clive's library, but the speed is as low as the previous one. That's odd, but I'm going to try to fix it. If You have any ideas please tell me about them :) 

EDIT 2: It turned out that I had a really slow SD card (class 2 ? ) and it was the problem ;) Hope it hepls !

Outcomes