AnsweredAssumed Answered

Trouble communicating with a new board design - SWD ERROR

Question asked by soren.eric on Jul 24, 2015
Latest reply on Jul 24, 2015 by Clive One
This is my first project with an STM part. I have started development on a NUCLEO board with an STM32F401RE chip and I'm programming/debugging using the onboard STLINKv2. So far firmware development has gone well. 

I designed a new board with the same chip (STM32F401RE) and I bought a second NUCLEO board to harvest the STLINK from. 

I cannot communicate with the new pcb at all -- from either STLINK, and I'm afraid I might have done something wrong in my schematic. 

I am attaching the schematic and a picture of my programming setup. 


Some notes: 

1. I have removed the CN4 jumpers on the STLINK board
2. I have tried with only SWDIO, SCK, GND, and VDD  (also trying with SWO and NRST)

3. I have tried various configurations of BOOT0, BOOT1, although by default BOOT0 = GND. 

4. I have tested continuity all the way between the pins and the STLINK and made the wires shorter. 

No matter what I do, when I plug in the STLINK board, the NUCLEO drive contains a file called fail.txt, which contains the text "SWD ERROR". And I am unable to connect or communicate with the target board from the STLINK software. 






Screen%20Shot%202015-07-23%20at%203.56.30%20PM.pngsetup.jpg


Outcomes