AnsweredAssumed Answered

reboot issue (setting SYSRESETREQ bit in stm32f411 & STM32F417) not working

Question asked by Teja on Jun 29, 2015
Latest reply on Jun 29, 2015 by Clive One
Hi STM,

I'm trying to reboot the board using NVIC_RESET, but its not working, when i traversed the i found that the NVIC_RESET is internally setting SYSRESETREQ bit in SCB->AIRCR register.

when i dig into arm info-center i understood there are two ways to do the reset
1) setting SYSRESETREQ bit in SCB->AIRCR (reset the CM4 + other soc parts)
2) setting VECTRESET bit in SCB->AIRCR (reset only CM4 core)

when i tried option 1) it not working and it moves to next line which is __DSB() and then to while loop

when i tried option 2) then the arm core reset is happening. so i want to know is there any problem with hardware or software,

little more observations did
>>when i toggle the reset pin of mcu its rebooting
>>when i force the watchdog to trigger its not working.

i want to know few pointers so that i can move forwared.

i have another board, its working fine (stm32f415)

Am i missing any configuration, pll configuration, pin configuration etc.....

and FYI  the BOOT0 is grounded, and BOOT1 is unused.

Appreciation in advance ;-)


Thanks,
Mani

Outcomes