AnsweredAssumed Answered

Error When Trying to Flash STM32F405

Question asked by roofie01 on Jun 19, 2015
Latest reply on Jun 22, 2015 by roofie01
Hello:

I have the STM32F405 target connected via ST-Link pod (using IAR EWARM) This is the second of 2 identical boards, the other flashes OK.

The ST-Link connects with no problem. When I initially just tried loading the program from EWARM, it reported a "Flash Error" and exited.
I then used ST-Link utility to look further. I selected "Program & Verify", then it said protection was enabled, and I selected "Yes" to disable it. The download dialogue pops up, and then another dialog pops up indicating an error:
"Programming error @ 0x2000098C" (!)... a screen capture is attached.

I've tried both setting and unsetting Level 0 & 1 option bytes. Each time it says "Could not set option bytes! Please reset the target and retry"

All pin voltages seem normal: the Vcap 1 and Vcap 2 voltages are 1.2V. See screen shot attached.

Any suggestions as to what is going on?

Attachments

Outcomes