AnsweredAssumed Answered

Another ST Link Can not connect to target error.

Question asked by Mahjoub.Youssif on May 21, 2015
Latest reply on May 22, 2015 by Mahjoub.Youssif
Hello,

I bought a ST link v2 and stm32f103 dev board from ebay (this one) plugged up the st link to the header on the board as such.
       
  • st link pin 19 -> 3.3v
  •    
  • st link pin 20 -> ground
  •    
  • st link pin  7  -> DIO
  •    
  • st link pin  9  -> clk
Downloaded ST link utility, upgraded the firmware on the ST link, and tried to connect to the MCU. I get the following error in the st link utility.

20:01:54 : Can not connect to target!
                  Please select "Connect Under Reset" mode from Target->Settings menu and try again.
                  If you're trying to connect to a low frequency application , please select a lower SWD Frequency mode from Target->Settings menu.
20:01:55 : No target connected

I've try every setting on the st link utility settings, including the instructions in the error, with no luck. I've also tried different boot pin configurations.

Here is what my device manager looks like, but it was able to update the firmware so i think the drivers are okay. "SM Bus Controller" is there even when the ST Link is not connected. I've also tried multiple computers and multiple versions of Windows with the same issue. It seems there is something wrong with the MCU it self, but i have no idea to test it. Also just FYI i can upload .hex files to the MCU just fine over UART1. I currently have a blink LED program running which uses pin PC13.

Outcomes