AnsweredAssumed Answered

Options not displayed in "coder target" tab for stm32f4-discovery microcontroller

Question asked by Billie1123 on Mar 31, 2015
Latest reply on Apr 1, 2015 by Billie1123

Hi, I am using simulink to program the stm32f4-discovery.
I have just realised that there are some features missing in the "coder target" tab of simulink. I have succesfully tried some of the demos of my stm32f4-discovery in order to learn how to set up the pins and some other basic stuff.

The problem is that now I want to switch to "external mode" so that I can read the information processed by the microcontroller in real time, but I can't see the "EXTERNAL MODE" option displayed under the "GPIO I" text. I neither can see the "Operating system options" gropubox that should be located at the top of the window.

For more clarity I will show you what the "coder target" window should look like (picture taken from a tutorial):

stm32f4discovery_extmode_1.png

And this is how it actually looks:

CODER%20TARGET.png

I am trying to reinstal the stm32f4-discovery support package but I don't think it will make any difference. I also remembered I blocked MATlab during some installation, I tried to unlock MATlab just in case the problem was a feature that couldn't have been installed, but I had no luck.

Any help would be really appreciated.

Regards

Outcomes