AnsweredAssumed Answered

STemWin -> GUI_Init() hangs after use of a 2nd Level Bootloader on STM32F429

Question asked by MM2forever on Jan 17, 2015
Latest reply on Jan 18, 2015 by MM2forever
Dear Forum Members,

I'm struggeling for quite a while now with this Problem:

I run STemWin, the precompiled emWin version lincensed for ST, on a ST32F429. Everything worked fine until I made use of OpenBLT, a second level bootloader.
If I try to flash my user application from SDCard that contains STemWin, the user application hangs at GUI_Init();

I expect it to have something to do with the memory allocation. So I'm asking if its in general not possible to run the precompiled STemWin from a flash location other than 0x08000000 ? Because I moved the user application 48K to 0x0800C000 because the bootloader occupies the space in front.

I suspect the Linker script to be faulty maybe also.

Also asked the same question in the Segger forums, no help so far. It maybe ain't a emWin issue therefore:

http://forum.segger.com/index.php?page=Thread&threadID=1889
(someone having almost the same problem - > unfortunately he didn't say what it was.)

I'm hoping that someone here can help me, I still couldnt solve the issue for quite a while now and it starts to get annoying ;)
Tell me if you need more info.
Thanks in advance!

Outcomes