AnsweredAssumed Answered

Programming STM32F103 discovery controller via UART1

Question asked by aruns06 on Sep 15, 2014
Latest reply on Sep 16, 2014 by aruns06
Hi,
I am trying to program the standard STM32F1 discovery board (STM32F103 controller) through usart1 (without using the stlink debugger integrated within the board). I have removed 2 jumper associated with CN2. Then I connected RX pin of the FTDI connector to Tx pin of the controller (PA9) and Tx pin of the FTDI to RX pin of the controller (PA10). The Board is not provided with any external crystal. The BOOT0 pin is kept at High and BOOT1  at low. Then I opened the application FLASH loader Demo by STMicroelectronics. Selected the Port, Parity None(Even and Odd also tried),Time outs(2-10 I tried), Board rate -9600 (Also tried 256000).  I reset the controller and then I click on next in the application and I'm able to program the board.

I have a custom board which is similar to the F1 Dev board. I tried the same on the custom board and I'm  not able to program it. The moment I click on the NEXT in the application I am getting an error message "Unrecognized Device. Please Reset and try again ". I'm not sure whether is controller is gone or not. How Do I check whether my controller is working or not????

regards,
Arun

Outcomes