AnsweredAssumed Answered

STM32F042K6 flash loader problem

Question asked by unal.murat.001 on Sep 11, 2014
Latest reply on Sep 14, 2014 by abovyan
Hi,
We started to use SMT32F042K6 microcontroller. I need to download program via serial port. So I am tring to use flash loader demonstrator v2.6.0.

First of all, I connected my board to PC via FTDI virtual com port device hardware in Boot mode. (115200br, 8bit, even, 1stop, no flow) I send 0x7F from a terminal program and I received 0x79 (ACK). I saw all bootloader commands which are describe AN3155 can be sent and received return messages.


When I run flash loader demonstrator, it says "target is readable, Please click the next to proceed.". When I click the next button, I saw
* Target combo box is empty
* PID: 0445
* BID: NA
* Version: 3.1
So I could not select MCU and I could not continue.


I decided to use STMFlashLoader.exe from command line to deal with this problem. I sent 
"STMFlashLoader.exe -c --pn 20 --br 115200 --db 8 --pr EVEN --sb 1 --ec OFF --co OFF --to 5000" to set serial port. I received OK message.
Then I sent,
"STMFlashLoader.exe -i STM32F0_Low-density_32K"
or 
"STMFlashLoader.exe -i STM32F0_32K"

everytime I receives 
"Activating Device    [KO]
No response from the target, Bootloader can not be started.
Please, verify the bootmode configuration, reset your device then try again.
Please, reset your device then press any key to continue."


When I run STMFlashLoader.exe in command line, I already checked serial port activity. The program (STMFlashLoader.exe) do not send any data via serial port until error message.


How can I fix the problem? Is there any way boot the MCU via serial port?

Outcomes