AnsweredAssumed Answered

Can't get SDW via ST-Link/v2 to work

Question asked by neff.vance on Jul 31, 2014
Latest reply on Aug 1, 2014 by neff.vance
Hi,

I just received a new prototype with a STM32F215 processor and it is set up to use the SWD interface to initially flash the unit.

on the ST-Link/v2 I have connected:
pins 3,5 & 10 to gnd (3 & 5 to reduce noise)
pin 9 to SWDIO on the processor
pin 11 to SWCLK on the processor

I have verified the following on the processor:
The VDDs are at 3.3v
BOOT0 is pulled to ground
BOOT1 is floating
Vcap_1 & VCAP_2 are at ~ 1.2 v
NRST & RESET are high
There is a clock on OSC_IN
VBAT is connected to 3.3 v

In the STM32 ST-LINK Utility:
Utility version v3.3.0
USB Driver version v4.3.1.0
ST-Link CLI version V1.9.0

ST-Link version V2.J21.S4 STM32+STM8 Debugger

Settings:
SWD
Coneect Under Reset and tried Normal and tried Hot Plug
Enable debug in Low power mode, tried unselected

When connecting, I always get:
Can not connect to target!
Please select "Connect Under Reset" ....
or If you're trying to connect to an STM32W1xx ...

I verified that there seems to be activity on both the SWDIO & SWCLK lines when attempting to connect.

Any hints as to what further to check?

Thanks for any help!
Vance

Outcomes