AnsweredAssumed Answered

STM32F405 cannot connect using SWD

Question asked by martin on Mar 28, 2014
Latest reply on Apr 1, 2014 by nouha
I'm having the same problem as the one [DEAD LINK /public/STe2ecommunities/mcu/Lists/cortex_mx_stm32/Flat.aspx?RootFolder=/public/STe2ecommunities/mcu/Lists/cortex_mx_stm32/STM32F4%20-%20No%20target%20connected&FolderCTID=0x01200200770978C69A1141439FE559EB459D7580009C4E14902C3CDE46A77F0FFD06506F5B&currentviews=1486]discussed here, i.e., I cannot connect to the stm32F405 using SWD on a board I built. The strange thing is that it was working correctly and then suddenly stopped. Thinking that I may have somehow damaged the stm32, I replaced it but the  symptoms are still the same. I'm using the stlink on a discovery F4 (fw version V2.J19.S0), it works correctly for the stm32 on the discovery board.

What I tried / verified

- The ST-LINK jumpers on the discovery F4 are off
- All power supply pins are at 3.3V
- VCAP1 and VCAP2 are at 1.2V
- VBAT is connected to 3.3V
- BOOT0 is connected to GND, BOOT1 is floating
- NRST goes high after powering on the device
- The SWCLK and SWDIO signals reach the pins (tested with oscilloscope)

Ideas for problems that could be causing this:
- Power supply rise time may be too slow. It takes about 800us to reach 3.3V when powering on the device. NRST goes high approx. 1.5ms after applying power.
- The current board revision only uses 100nF decoupling capacitors, i.e., the 4.7uF cap on VDD and the 1uF VDDA are missing. This will be fixed in the next revision. BTW: is it fine to use 2.2uF on VDDA instead of 1uF?
 
Any tips on what else to test are highly appreciated.





 













  

Outcomes