AnsweredAssumed Answered

Connecting to STM32f0 with ST-Link Utility (SWD)

Question asked by bolijn.ronald on Jan 21, 2014
Latest reply on Dec 18, 2016 by S. Marsanne
I'm having some troubles connecting an ST-Link to a STM32f0 microcontroller. Did is what i did/tried:
       
  • Soldering STM32f051 (LQFP48) to DIP adaptor
  •    
  • VBAT, VDDA, 2x VDD to +3,6V
  •    
  • VSSA, 2x VSS to GND
  •    
  • BOOT0 to GND
  •    
  • NRST with pullup to +3,6V (pin is not internally pulled low)
  •    
  • VDD, VSS, SWIO and SWCLK to 20 pin connector ST-Link
When i tried to connect with ST-Link Utility I get error "Can not connect to target!". I used the same ST-Link to connect to a STM32F051 Discovery Board (disabled on board st-link) and succesfully connected, so driver and connections seem ok.

Next thing i tried was resetting the MCU with BOOT0 pulled to +3,6V. I send 0x7F to USART1 with HyperTerminal and received 0x79 back. So the bootloader (and thus internal clock?) seem to be working.

Does anyone have any idea? Is a different approach required for first time programming?

Thanks for the help!

Ronald

Outcomes