AnsweredAssumed Answered

Program upload and Erase from IAR not working

Question asked by Leon32 on Oct 3, 2011
Latest reply on Oct 8, 2011 by Clive One
I've been using this forum to get started with my STM32VLDiscovery board and EWARM6, and it really helped me out. Thank you all very much.

I have an issue now, though. I have 2 VL Discovery boards, used to play with one of them, the other is still new. After a couple of weeks, during a standard flashing procedure, something went wrong and the flashing was terminated with an error. If i try to perform it again, it shows an error that the flash program can't be started. I close the IAR and reopen it, start the flashing procedure - and the board starts blinking with the comms led endlessly. if i click on cancel, it stops blinking, and again i have to reopen the IAR to perform another attempt. Same thing happens with Erase function. Tried different computers.
I took the new board, it flashed once, and on the second time did the same thing. Nevertheless, Erase function worked well with it, but now i'm kind of afraid to go on and use it, it is my last board.
I tried using the boot pin as i saw on one of the posts, didn't help.
Is my board dead? What can be wrong?
Thanks!

Outcomes