AnsweredAssumed Answered

UART bootloader version 3.0 problems

Question asked by lucas.andrew.001 on Aug 27, 2013
Latest reply on Aug 27, 2013 by Clive One
We are using STM32F205 parts.  I have developed my firmware update code based on version 3.1 of the UART bootloader.  Today we discovered a few of our devices had version 3.0 of the bootloader installed and consequently were failing the firmware update.  I have attached screen shots of the issue.  As you can see with version 3.0 the slave is driving its transmit (the master receive) line low at the same time as the 0x7f is being transmitted to it.  You can also see that with version 3.1 this behavior is not seen.  The bootloader protocol document does not seem to document this behavior anywhere on the version evolution page.  Has anyone else seen this behavior and what did you do as a work-around.

Thanks.
Andrew Lucas

Attachments

Outcomes