AnsweredAssumed Answered

bluenrg MS setup ok, but no connetion established

Question asked by dalla_via.enrico on Nov 17, 2015
Latest reply on Nov 19, 2015 by dalla_via.enrico
Hello,
I'm having a lot of trouble working with a bluenrg MS. I have initially developed my code with an stm32f429-discovery and a dashboard that comes with evaluation board of bluenrg (NOT bluenrg MS!). All works fine, I can setup the bluetooth and load custom services which I can see from a test app on my android phone.
Now I have switched to a different custom board, which has the same processor stm32f429 but with a  bluenrg MS chip for the bluetooth. I can setup the chip but when it comes to accept remote connection from my app, I can't see any interrupt on the line and the app gave to me a timeout.


Following the output I captured from uart
ver=0 hwVersion=31 fwVersion=710

BlueNRG_RST                                                                                                 
Setting BD_ADDR OK                                                                                                                                                                                                                            
GattInit                                                                                                            
GATT_Init OK                                                                                                                    
GAP_Init OK                                                                                                                    
aci_gatt_update_char_value OK                                                                                                                    
aci_gap_set_auth_requirement OK                                                                                                                
SERVER: BLE Stack Initialized                                                                                                    Add_GlassUp_Service                                                                                 Serv: handle=0x000C uuid=FB349B5F8000008000100000001B0000                                                            
servConfigCmdHandle=0x000D                                                                                                                                                                                                                    
servConfigNtfyHandle=0x000F                                                                                                                                                                                                                   
Serv: handle=0x0016 uuid=FB349B5F8000008000100000002A0000                                                                                                                                                                                     
appConfigRequestHandle=0x0017                                                                                                                                                                                                                 
appConfigBurstStatusRequestHandle=0x0019                                                                                                                                                                                                      
appConfigAddDelHandle=0x001B                                                                                                                                                                                                                  
appConfigNtfyHandle=0x001D                                                                                                                                                                                                                    
appConfigBurstStatusHandle=0x0021                                                                                                                                                                                                             
Serv: handle=0x002A uuid=FB349B5F8000008000100000003A0000                                                                                                                                                                                     
appContentRequestHandle=0x002B                                                                                                                                                                                                                
appContentBurstHandle=0x002D                                                                                                                                                                                                                  
appContentNtfyHandle=0x002F                                                                                                                                                                                                                   
appContentStatusHandle=0x0033                                                                                                                                                                                                                 
GlassUp service added successfully                                                                                                                                                                                                            
HCI_Event_CB                                                                                                                                                                                                                                  
Unmanaged GATT event: 0x1                                                                                                                                                                                                                     
set_connectable

at this point I enter in the loop that calls
HCI_Process()
User_Process()
but no matter what, I can't connect to bluenrg even if I can see if on the list of device on my phone.
Any idea about hoe could be the problem?
Many thanks

Outcomes