AnsweredAssumed Answered

Error in Initializing ST-Link device

Question asked by soni.rajan on Sep 27, 2011
Latest reply on Oct 21, 2015 by Clive One
Hi, 
Just started playing around with my STM32 discovery board, and had a problem right away. I'm using atollic trueStudio IDE and trying to load a demo project(the one in firmware package), to my microcontroller. The thing is everytime I hit debug button It shows this in console:
Starting server with the following options: 
        Persistant Mode            : Disabled 
        LogFile Name               : debug_log.txt
        Logging Level              : 1
        Listen Port Number         : 61234
        Status Refresh Delay       : 15s
        Verbose Mode               : Disabled 
        SWD Debug                  : Enabled 
Error in Initializing ST-Link device
I spent entire day searching web, if I could find a solution but no success yet. I found this page(http://www.atollic.com/index.php/kb/3-debugging/28-kb_st_link_connection_error) on atollic website, have followed the steps but still no luck. So these are the things which I have already tried:
- checked USB cable
- tried running ST-LINK GDB server, same error
- checked the driver installation, and updated to latest version
- no disk letter issue, st link is using G: and it is vacant
I have followed the user manual steps exactly still unsure what's wrong with my board. Any help appreciated.

Outcomes