AnsweredAssumed Answered

STM32F4 - "No target connected"

Question asked by gomberg.brian on Jan 19, 2013
Latest reply on Jan 20, 2013 by Clive One
I have recently assembled the first prototype of a new board I'm working on for a project and have so far been unsuccessful in connecting to it with the STM32 ST-LINK Utility. The chip I'm using is the STM32F407VET (100-pin package) silicon revision Z. I am using the ST-Link/V2 programmer.

Here's what I've tried:
1) Programming over SWD with NRST, SWIO, SWCLK, 3V3 (from target), GND connected as described in the ST-Link manual gives "No target connected." Checked that the preferences were set to use SWD and not JTAG and tried both combinations of "Connect under Reset" (not sure what this does - but got same result either way).
2) Programming over JTAG got the same error (got "Unkown target connected" a few times as well).
3) With BOOT0 pin connected (directly) to 3.3V, got a 0x79 response from sending 0x7f over USART3 (via Sparkfun 3.3V FTDI board). No response with BOOT0 connected to GND through a 10k pull-down.
4) Checked with an oscilloscope that SWDIO and SWCK were active when trying to connect.

Here's some info about my board, including some mistakes I've noticed since making this first version.
1) VBAT was originally tied to ground. Not sure if this did anything but de-soldered pin and connected to 3.3V with no effect. It's currently not connected to anything.
2) BOOT1 is connected via 10k resistor to GND.
3) PDR_ON connected directly to GND.
4) With the programming not connected, I get 1.259V on VCAP (pin 49) and 0V on VCAP2 (pin 73). Both 2.2uF capacitors are a bit further away from the chip than they probably should be with VCAP2 being .5 inches between pin and capacitor.
5) I'm 99.99% sure the chip is in the correct orientation, with the dot in the pin1 corner (bottom left corner when oriented so the text is readable).

Looking at the power inputs, I've noticed they are very noisy (probably thanks to the switching regulator I'm using for 5V - 3.3V regulator in series after it). I could definitely see how this could be a problem and am trying to fix it (will post results shortly), but it's curious that my USART3 experiment still worked. Anything else I could try or anything I'm doing wrong? Thanks!

EDIT: I tried again with a clean external power supply powering the 3.3V lines on the board with no success.

Outcomes