AnsweredAssumed Answered

STM32F2 SWD debug impossible [SOLVED]

Question asked by de_biaggi.matteo on Jan 16, 2013
Latest reply on Jan 18, 2013 by de_biaggi.matteo
Hi at all,
I read swd related post in this forum but i'm still unable to start debugging on stm32f2 chip through SWD interface. 

I tried with ST-LINK V2 and with SEGGER J-LINK (supporting swd), more o less with same result.
I got an SWD connector with vdd,gnd,swdio,swclk.
NRST is not connected ( i suspect i need it ..)
No pull up or pull down on swdio pin.
I got the same issue on 3 different boards.
I set swdio and swclk as alternate 0.
I can write chip flash only with BOOT 0 set to High..
Program on flash act correctly.
I use the same scheme for other family chip like stm32l1 with no issues..

So maybe i miss some pin configuration or swj register(does it exists on stm32f2?) or the lack of nrst pin connected to debugger is the cause or what else ?

Note that executable on flash at the moment is simple, i dubt it could block swd except for un uncorrect pin configuration..

If you need other info to narrow the problem just ask..

Thanks in advance Matteo.





Outcomes