AnsweredAssumed Answered

STM32F4 debugging with ECLIPSE JUNO

Question asked by burger.ben.001 on Dec 22, 2012
Latest reply on Dec 23, 2012 by Susilo.Ekawahyu
Hi all
It is out of desperation that I turn to the forum, I`ve read all I could find on the WEB regarding my issue, and after 2 weeks still no results:
1- I use the SMT32F4-DISCOVERY board which has the ST-LINK V2 built in
2- I want to use the GNU route as this is the cheapest option, but as always the most frustrating
3- I have all the GNU tools and ECLIPSE functioning and compiling, linking etc.
4- I can invoke the debug tools but..... this is the problem:
I use the Atollic TrueSTUDIO gdbserver for ST-Link.  Version 1.6.0  Pro
Copyright 2010-2012... This is supposed to connect with the GDB tools that I use with ECLIPSE but to no avail. I have tried CODESOURCERY, YAGARTO.. no matter what the error is always the same:
Starting server with the following options:
        Persistant Mode            : Enabled
        LogFile Name               : debug_log.txt
        Logging Level              : 31
        Listen Port Number         : 61234
        Status Refresh Delay       : 15s
        Verbose Mode               : Disabled
        SWD Debug                  : Enabled
Connecting to the ST-Link Debugger... OK
Waiting for debugger connection...
!!! At this point the server is running !!!!
Then as soon as you open the GDB tools to debug it exits with this message:
Connecting to the ST-Link Debugger... OK
Waiting for debugger connection...Error while waiting for debugger connection.
Shutting down...
Debugger connection lost.
Shutting down...
Everything seems to point to the server as I have tried many tools and they all do the same...

Any solutions
Thanks
Ben

Outcomes