AnsweredAssumed Answered

USB DFU fails on STM32F205

Question asked by blandford.michael on Dec 21, 2012
Latest reply on Dec 29, 2012 by blandford.michael
I'm attempting to get DFU over USB working on a STM32F205VET6. Chip marking:
STM32F205
VET6        X
HPABG    VG
KOR   HP   225

Computer Windows 7 64-bit Intel Pentium dual core processor
The BOOT0 input is derived from USB-VBUS, power is NOT USB. So plug in USB, power up processor. PC plays USB device connected sound, then reports "unrecognised device".
Using a 'scope I can see several transactions on the USbus.
Elsewhere I can see a reference to "Windows has stopped this device because it has reported problems. (Code 43)".
Checking with device manager, I've tried updating the driver manually, it just reports no driver is necessary for this device.
Also tried this on my laptop with windows XP, similar result although XP does report VID and PID both as 0000 (Win7 doesn't reports and VID or PID values.

I can get the bootloader to work using the serial connection, so I know the BOOT0/BOOT1 pins are correct.

This is on equipment provided to me for evaluation. It will need to be easily field upgradeable by users so USB is a MUST.

Thanks in advance for any help/information.

Outcomes