AnsweredAssumed Answered

ST-Link Connection Error Using SWD

Question asked by ofri.igal on Oct 31, 2012
Latest reply on Nov 5, 2012 by ofri.igal
Hi all,

I used STM32F4Discovery successfully using SWD and IAR to develop my application.

Today I got my boards, they have STM32F405RG on them (the Discovery has the 407).

I tried to connect to the board using Segger J-Link (I setup the correct options in the project options) but it could not connect.

So, I removed SB11 from the Discovery board and connected the SWD header to my board. Initially, when the board is "virgin" it will seem to connect but not reach 'main' in the application, and there will be no response from the MCU on the board.

Once the board is not "virgin" anymore the ST-Link gives "USB Connection Error" or "Reset failed - Target not halted" message, followed by "Failed to load flash loader....".

The SWDIO pin has 100K pullup, the NRST has 100K pullup (initially 51.1K but I tried to mimic the Discovery board once nothing worked), BOOT0 is pulled low using 510 Ohm as in the Discovery board.

I'm sure my code is not to blame since I use it frequently on the Discovery board.
I looked at the NRST pin and it will not drop to 0, seems the ST-Link has a problem pulling it low, it has some kind of noise whenever I try to use the ST-Link.

I attached a drawing (PDF)

Any ideas?
Thank you

Attachments

Outcomes