AnsweredAssumed Answered

STM32 F103xx using PB3

Question asked by gin23 on Sep 20, 2012
Latest reply on Jan 3, 2013 by Devilar
Hello,

We want to use PB3 of the microC. As found in some forums we have to disable JTAG. We do this using following line of code:
GPIO_PinRemapConfig(GPIO_Remap_SWJ_JTAGDisable, ENABLE);
Then we want to use PB3 as output. But the signal is low.

So far this helped us a lot: link

Only if we switch of the power of the microC and switch it on again, the pin will output the signal.

It seems that the debugger (jLink using SWD) isnt able to reset the microC completely. We tried different options of resetting in the IAR Workbench for ARM Debugger Options Menu.

In this pdf (link) it is described in chapter 9.3.5 (JTAG/SWD alternate function remapping) that PB3 is only free if no asynchronous trace. We aren't able, or do not know how to setup asynchronus trace. We don't use it with our SWD debugger. PB3 is also not connected to the debugger.

We also tried to make the full remap
GPIO_PinRemapConfig(GPIO_Remap_SWJ_Disable),
because there it isn't the footnote on PB3, but also there, it is not working after flashing, But it is working after reconnect the power.

By the way, we are able to work with PA15 and PB4 after calling GPIO_PinRemapConfig(GPIO_Remap_SWJ_JTAGDisable, ENABLE).

Do anyone of you have any experience with that and can you give us an advice?

Outcomes