AnsweredAssumed Answered

STA350BW write coefficients

Question asked by HarryHirn on Jan 15, 2015
Latest reply on Jan 19, 2015 by zhao.yuntao
hi all,

i am building an demo application that works right from powering up.
Therefore i added an I2C Master to the STEVAL-CCA035V1 and STEVAL-CCA030V1.

I can succesfully write the registers of the device and i can also verify that with the APWorkbench.

But i am having problems with the coefficients...

I dont know why but at first power up everything is working except the equilizer, i.e. the coefficients are not loaded correctly and the sound is therefore uneffected.
The rest of the configuration works, i can hear the correct sound.

If i let the same script run a second time then the coefficients are loaded and the sound is as expected.

is there any action i have to do to load and activate the coefficients?

i tried several ways:
single coefficient write, set of coefficient write (datasheet page 66).

with a logic analyzer i reconstructer the method from the APWorkbench and did the same with my controller.

first i noticed is that the order is other than that from the datasheet.
APWorkbench does the steps in the order

3 - 4 - 5 - 6 - 7 - 8 - 9 - 10 - 11 - 12 - 13 - 14 - 15 - 16 - 17 - 2 - 18

this is writing the registers for the coefficients first and then the adress plus trigger.

the datasheet says first ram block, then adress, then coefficients and at the end the trigger.

i dont think this is crucial because every variant i tried results in the same behavior.

i dont get the coefficients into the ram at first try.

any idea on this?

Outcomes