AnsweredAssumed Answered

[STM32F205RG] MCU seems to lock itself.

Question asked by Legrand.Thomas.001 on Jul 13, 2011
Latest reply on Jul 13, 2011 by Clive One
Here is the full story ...

I re-designed an existing product which was based on a PIC24HJ128GP202 (16 bit, 40 MIPS from Microchip).

The new version uses an STM32F205RG (TQFP64).

Physically, all JTAG + RST signals are available on the JTAG connector as in the ST Link documentation ( http://www.st.com/internet/com/TECHNICAL_RESOURCES/TECHNICAL_LITERATURE/USER_MANUAL/CD00221563.pdf ).

I use an ST Link V1 probe with latest firmware (J12).

First I tried Atollic TRUEStudio PRO (eval), everything worked for 1 or 2 days then their stlinkgdbserver.exe kept crashing each time I started a debug session.

I could connect to the MCU via ST link utility, but when trying to "run" from the core panel, each time got an error message "unable to run application".

I changed the MCU (desoldered / resoldered another one), and switched to TASKING VX-Toolset for ARM v3.1R2 (eval too).

Everything went good for 2 days, developped some features based on USARTs and TIMs (OC/IC), and yesterday, started to get error message when starting a debug session.

Today, plugged everything, and impossible to start a debug session (unknow ST Link error). Using ST Link utility, the logs says it can connects with JTAG but the MCU is not responding.

The program is running (LED is switched on), but it seems I cannot talk to the MCU.

I changed the MCU again (even changed the whole board, soldered a new one), first no problem using STLink utility, can connect, read flash, etc. Then downloaded the HEX file and the MCU disconnected (running the program ...).

My only guess is the MCU is entering read out protection level 2 (thus disconnecting the JTAG port) ... but nowhere in my code I intent to do this !

I'm really on a hurry for dev, and I already lost almost a week on this (first with Atollic, now with TASKING). TASKING support is searching.

I really need help. I already "fried" 4 MCUs, and they'r not cheap ... but I mainly loose precious time.

Is there something I can do to check the MCU has entered ROP level 2 (it's irreversible ...)?

Is there a incompatibility between ST Link and the STM32F205RG chip?

Why the hell is it working 2 days then suddenly it stops?????
I mean if it was a design flaw in the board, it would just now work at all... 

Is there a bug somewhere? In the MCU? In the STLink?

Is someone working with this chip (STM32F205RG in TQFP64 package) for more than a week? With which probe and toolset?

Regards,
Thomas Legrand.

Outcomes