AnsweredAssumed Answered

STM32F103RBT6 development board + 2.8" TFT-module

Question asked by levi.tzion on Jun 25, 2011
Latest reply on Feb 22, 2013 by Clive One
Hey people,
Recently I bought the STM32F103RBT6 development board + 2.8" TFT-module. (A.k.a MINI-STM32-V3.0) (with the 2 mini USBs)

After many attempts to enter programming mode, and program it via USB without any extra tools, I managed.

i used this combination to enter the programing mode:
(PRESS and HOLD the BOOT0 key, Press and Release the RESET key, Release the BOOT0 key)

i used the PL2303 Driver to set my "USB to Serial"  Virtual COM

and i used the "Flash Loader Demo" to upload the example code to my board.

The program worked and everything was good ...

but When I tried again to enter programming mode (in order to change the code),
the STM32F103RBT6 stuck on the programming mode (white screen).

i tried to program it (in the same way i managed before) but nothing,

Now, when ever i power up my board i see a white screen, the four keys (RESET, BOOT0, KEY1, KEY2) doesn't respond and the
"Flash Loader Demo" application cannot communicate with the board.

I am really afraid that somehow my board has
Bricked\Spoiled.
I will
Appreciate any help in this subject, thanks

Outcomes