AnsweredAssumed Answered

STM32L476G-EVAL Bootloader UART/CAN issues

Question asked by mabo on Jul 22, 2016
Latest reply on Oct 17, 2016 by Montassar BEN ROMDHANE
Hello together,

I just want to find out how to use the basic bootloader operations on an STM32L476G-EVAL board. I read all the application notes (AN2606, AN3154, AN2557, AN3156) and the manuals for the board and the MCU itself.

If I start the bootloader by configuring the switch BOOT0 -> 1 the DFU mode is working properly with the DfuSe Demo (v3.0.5). But I wasnt able to call the basic CAN commands on the device.
Because of this trouble I started to try the USART connection, but I wasn´t able to send any command or receive anything from the device. I tried to use the Flash Loader Demonstrator without success. I also changed the power supply to an external one connected to the CN22 (also set JP17 to P5V) power jack to avoid any connection that maybe cause an error. Nothing is connected to the board instead of the 5V power plug and the RS232 wire connected to USART1.

I read a lot of using the USART in this forum for the bootloader and so I tried to send the 0x7F manually to get the 0x79 ACK in "HTerm" but nothing happened.
I know the settings have to be 8E1 and I tried different baud rates.

I also cheacked the bootloader version at address 0x1FFF6FFE = 0x92 so it seems to be up to date.

I´m running out of ideas... What I don´t know is, if there is any setting that I maybe forgot? I read about the bootloader, that all the USART receive Pins need to be connected to 1 or 0 to avoid floating. Is it possible that there is an issue especially to this board?
I didn´t find so many detailed information about this board.

It would be nice if anybody could help me with this, who has experience with the SMT32L476G-EVAL board and the bootloader thematic.

Regards and thank you in advance

mabo

Outcomes