AnsweredAssumed Answered

Bricked?

Question asked by a. richard on Oct 17, 2010
Latest reply on Oct 17, 2010 by a. richard
Hello,

I seem to have bricked my board. I have been experimenting with different compilers and linkerscripts, and probably something was messed up.

None of the three IDEs will to establish contact with the board. The ST-Link utility which can flash binary files to the chip won't let me flash anything, saying that readout protection is active. If I try to remove readout protection from the ST-Link utility, it just hangs. (LE: and after 5-8 minutes it errors "cannot set option bytes: please reset the device and try again") If I remove the readout protection via USART, it says it's successful, but again I'm not able to flash anything via ST-Link.
As you might know, the USART flashing tool from ST doesn't have any data for stm32f100, so you can't flash/read the chip from it.

I have also tried this on linux, using stm32loader.py and a C tool. Using a binary I have tested earlier, that flashes the two on-board leds, I have flashed the board over USART using the two tools mentioned above. Each time, after flashing, I have reset the board and set BOOT0 to logic 0, but the program won't start anymore.

The communication protocol over USART seems ok though, I've even tried reading the chip ID and supported commands manually and it works. The ST-LINK chip also seems to work, since the 30MB drive with the three files is created.

My initial suspicion was that some runaway code disable JTAG, but that would have been solved by erasing the chip over USART.

The only modifications to the board are removing PB10-PB15 so it can fit in a breadboard, and removing the BOOT0 jumper (J16 iirc, not sure) so I can use the USART bootloader.

Anyone experience this before?
Thanks

Outcomes