AnsweredAssumed Answered

Flash Loader fails system boot with STM3220G-EVAL

Question asked by hairy.lee on Nov 18, 2015
Latest reply on Nov 20, 2015 by hairy.lee
Hi,

I have a STM3220G-EVAL board that I am trying to flash using CN16 (USART3) and the Flash Loader Demonstrator. I have tried both v2.5.0 and v2.8.0 of the Flash Loader and get the same result; either "Unrecognized device..." or "No response from the target".

I can enter the system boot mode in 1 of 3 ways:
1. Set BOOT0 == 1 and hit the RESET PB;
2. Hit the Key PB which initiates a PC (0x1fff0004) + MSP (0x20001000) boot jump;
3. Hit the Tamper PB which initiates a write to RAM (0x2000FFF0), forces a reset, checks RAM for the written var in startup and then branches to 0x1fff0004.

I have setup a script running through my serial terminal and have confirmed that I am able to send the commands specified in AN3155 (USART protocol used in the STM32 bootloader) and can confirm that I get positive responses for all messages except Erase and Extended Erase. I'm able to write and readback from RAM (0x2000FFF0) and Flash (0x0800127C) which overwrites the (const) variable defined to be written to RAM. 

Each approach for entering the system boot mode works with my script, but none work with the Flash Loaders. Kind of run out of ideas now so any suggestions would be appreciated.

Thanks

Outcomes