AnsweredAssumed Answered

[Solved] Discovery f429 USB Host (usb stick not working)

Question asked by Couniot.Raphael on May 12, 2015
Latest reply on Oct 27, 2015 by beck.joseph
Hi,
I worked for several weeks on a dictaphone project with the board F429 discovery. The goal is to write the values of the ADC to a file on a USB key.

My ADC works with DMA, everything is ok.

However, I generated my file with CubeMX (for Keil), I added the content in the "USBH_LL_DriverVBUS" function.

The problem is: Appli_state never changes to "Ready" and the LED of the USB key does not light.

In debug mode, the microcontroller starts, then I plug the USB key, gstate = Host_Iddle. Then gstate = HOST_ENUMERATION RequestState and remains at "CMD_Wait" ... And USB Status is always "busy" ...

I tried the example "FW upgrade USB" and "USB-FATFS" but I find no difference between them and my project.

What to add / change the code generated by Cube for the USB key working?


My board works at 168MHz, I included USB Host, FATFS support, etc ...

Thank you in advance, I can not see what to try ...

The problem was that :
#define USBH_MAX_SIZE_CONFIGURATION      512 //255 by default in CubeMX
#define USBH_KEEP_CFG_DESCRIPTOR      0  //1 by default in CubeMX

Outcomes