AnsweredAssumed Answered

STM32F4 Discovery TCP problem

Question asked by van_vinh.huynh on Mar 2, 2015
Latest reply on Mar 4, 2015 by AvaTar
Hello, 
I am trying to implmenet TCP server on my STM32F4 Dis which connects to a client computer via Ethernet. The Client computer keeps sending connection request and data to the server and receives the data from the server. It is 1 client- 1 server model. Everything works just fine but then, when I unpluged the power suplply for STM32F4 Dis board for > 20 secs and pluged it back, the TCP connection breaks. ( no data received, cannot ping). I tried to unplug/replug the ethernet cable, reboot the client computer, still not working. However, if I unplug then plug back the STM power supply in <5sec, the TCP connection restores ( if I plug back after > 10sec, it does not work). After so many testing, I know that if I unplug then replug the STM power after >10 sec, the TCP connection breaks. The only way to restore is to unplug then replug STM power in <5sec. May I know any reason causing this happen and what is the solution for that?
Thank you.

Outcomes