AnsweredAssumed Answered

Debugging problem: No ST-LINK detected

Question asked by el_gharbi.khaled on Feb 18, 2015
Latest reply on Dec 2, 2015 by Chan
Hi, there is something wrong with my STM32F4 Discovery board, I cannot get the debugger working, with the IAR workbench it sais the "the flash loader program reported an error" and the next pop up window sais "the debugging session could not be started, either the debugger initialization failed or else the file "D:\My_STM32F4_Projects\Follower_Avoider\Debug\Exe\c.out" was corrupt or of an unsupported format. There might be more information in the debug log window.
I tried with simple bliking led programs but none of them worked.
When I try to connect the boad with ST-LINK Utility it sais No ST-LINK detected.
I tried another F4 Discovery board --> the same thing. I also blugged my card in another computer, when I clicked on debug it sais "the flash loader program reported an error".
 I don't know how to fix this problem, I've been searching for 2 weeks now, I couldn't find any solution. can you please help me

Outcomes