AnsweredAssumed Answered

STM32f2xx SWD programmer problem

Question asked by ma.andrei on Feb 9, 2015
Latest reply on Feb 10, 2015 by AvaTar
 Hi at all,

I would try to program a custom made board with STM32f205RCT7 micro onboard via SWD .
I got an SWD connector with vdd,gnd,swdio,swclk,nrst.
No pull up or pull down on swdio pin , 10k ohm pull up on nrst and 1nF to GND.
10k ohm pull down on BOOT 0 .
I am use STM32 ST-LINK utility ( Connection protocol  SWD).
This is the message I get :

15:11:46 : ST-LINK Firmware version : V2J22S4
15:11:46 : Connected via SWD.
15:11:46 : Connetion mode : Connect Under Reset.
15:11:46 : Device ID:0x411 
15:11:46 : Device flash Size : 256KBytes
15:11:46 : Device family :STM32F2xx
15:11:46 : Can not connect to device!

I tried to remove nrst 1nF capacitor but it did not help.
I tried on 2 different boards, is it the same problem.
The Vcc is OK. Vcap_1 and Vcap_2   1.2 V . I am check swdio,swclk,nrst with oscilloscope and it looks good.

I have another board (very same to the first , base on STM32f205RCT6 and  SWD connection too) and its work perfect in the same setup.




 

Attachments

Outcomes